How to mirror vg00 using LVM on IA with 11.23
==============================================
for rx6600 : 10.191.29.29
1. From HPUX, use vgdisplay to identify the disk that is in vg00. Use ioscan to find the spare disk.
# vgdisplay -v --> vg00 is on /dev/dsk/c2t0d0s2 in this example
# ioscan -efunC disk --> Let's assume c2t1d0 for this example as spare disk
1.1 Remove disk from vg <<--------------------
# vgreduce /dev/vg00 /dev/dsk/c2t1d0
2. Create the system, OS, and service partitions.
echo "3\EFI 500MB\HPUX 100%\HPSP 400MB\" >/tmp/partitionfile
# vi /tmp/partitionfile
3
EFI 500MB
HPUX 100%
HPSP 400MB
# idisk -wf /tmp/partitionfile /dev/rdsk/c2t1d0
idisk version: 1.31
********************** WARNING ***********************
If you continue you may destroy all data on this disk.
Do you wish to continue(yes/no)? yes <-- Answer "yes" and not "y"
3. Create device files needed for the new partitions.
# insf -eC disk
4. Verify the partition table.
# idisk /dev/rdsk/c2t1d0
5. Verify that the device files were created properly.
# ioscan -efnC disk --> c2t1d0 is 0/1/1/0.1.0
6. Populate the /efi/hpux/ directory in the new EFI system partition.
# mkboot -e -l /dev/rdsk/c2t1d0
7. Change the auto file for the mirror to boot without quorum.
NOTE: Using "s1"
# echo "boot vmunix -lq" > /tmp/AUTO.lq
# efi_cp -d /dev/rdsk/c2t1d0s1 /tmp/AUTO.lq /EFI/HPUX/AUTO
NOTE: We assume that if we boot from the primary, the mirror is fully
functional and therefore we don't need to override quorum. Your site
might require that both disks override quorum.
9. Verify the contents of the auto file on the primary and the mirror.
NOTE: Using "s1"
# efi_cp -d /dev/rdsk/c2t0d0s1 -u /EFI/HPUX/AUTO /tmp/AUTO.pri
# efi_cp -d /dev/rdsk/c2t1d0s1 -u /EFI/HPUX/AUTO /tmp/AUTO.alt
# cat /tmp/AUTO.pri
# cat /tmp/AUTO.alt
10. Add the new partition to vg00.
NOTE: Using "s2"
# pvcreate -fB /dev/rdsk/c2t1d0s2
# vgextend vg00 /dev/dsk/c2t1d0s2
11. Mirror all logical volumes in vg00.
NOTE: Using "s2"
# lvextend -m 1 /dev/vg00/lvol1 /dev/dsk/c2t1d0s2
.
---or create a .sh file , and execute it------------------------
lvextend -m 1 /dev/vg00/lvol1 /dev/dsk/c2t1d0s2
lvextend -m 1 /dev/vg00/lvol2 /dev/dsk/c2t1d0s2
lvextend -m 1 /dev/vg00/lvol3 /dev/dsk/c2t1d0s2
lvextend -m 1 /dev/vg00/lvol4 /dev/dsk/c2t1d0s2
lvextend -m 1 /dev/vg00/lvol5 /dev/dsk/c2t1d0s2
lvextend -m 1 /dev/vg00/lvol6 /dev/dsk/c2t1d0s2
lvextend -m 1 /dev/vg00/lvol7 /dev/dsk/c2t1d0s2
lvextend -m 1 /dev/vg00/lvol8 /dev/dsk/c2t1d0s2
-------------------------
12. Add the new disk to /stand/bootconf.
NOTE: Using "s2"
# vi /stand/bootconf
l /dev/dsk/c3t7d0s2
l /dev/dsk/c2t1d0s2
13. Verify that the new disk was added to vg00, and the lv's are in sync.
# vgdisplay -v vg00
14. Verify that the BDRA was updated properly. Take note of the HW ths for step 15.
# lvlnboot -v
15. Add EFI primary and high availability boot path menu entries.
# setboot -p 0/4/1/0.0.0.7.0 <-- Set primary disk
# setboot -h 0/4/1/0.0.0.6.0 <-- Set mirror disk
# setboot -b on <-- Set autoboot on
16. Verify that the primary and mirror boot paths are configured properly.
# setboot
17. Test the new mirror by booting off of it.
# shutdown -r -y 0
18. Select "HP-UX HA Alternate Boot" to test the mirror.
EFI Boot Manager ver 1.10 [14.61] Firmware ver 2.21 [4334]
Please select a boot option
HP-UX Primary Boot: 0/1/1/0.1.0
HP-UX HA Alternate Boot: 0/1/1/1.2.0
EFI Shell [Built-in]
20. Verify which disk/kernel you booted from.
# grep "Boot device" /var/adm/syslog/syslog.log
vmunix: Boot device's HP-UX HW path is: 0.1.1.1.2.0
21. Remove temporary files.
# rm /tmp/partitionfile /tmp/AUTO*